常見問題集

如果你在安裝 EmEditor 時遇到問題,請先閱讀這個

如果你在安裝 EmEditor 時遇到問題,請先閱讀這個

如果你在安裝、卸載或更新 EmEditor 時遇到問題,請參考下面的提示。我們很抱歉給你造成的任何不便。

  1. 如果你用 Trend Micro,Avast,或任何防病毒軟件,請暫時禁用該軟件并安裝 EmEditor。
  2. 關閉所有目前的運行的程式包括在工具列的通知區域上的圖示。
  3. 通過更新 Windows 和重新啟動 Windows,檢查 Windows 系統是否是最新的。
  4. 磁盤清理來清理系統檔案。要運行磁盤清理,你可以先從任務欄搜尋磁盤清理,點擊清理系統檔案,然后清理所有檔案。
  5. 刪除在 %TEMP% 資料夾中的所有檔案,然后重新啟動 Windows。
  6. 當你更新或安裝 EmEditor 時,如果有錯誤消息「無法訪問您要使用的功能所在的網絡位置。」顯示,首先定位前一版本的安裝程式。前一版本的安裝程式通常能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 資料夾中找到。如果沒有,一些舊版可以從 http://files.emeditor.com/emed64_xx.x.x.msi (64-bit) 或 http://files.emeditor.com/emed32_xx.x.x.msi (32-bit) 上下載,這裡的 “x” 代表版本號。例如,你要下載 v18.9.0 (64-bit) 的安裝程式,你的下載連結就是 http://files.emeditor.com/emed64_18.9.0.msi。最後,點擊錯誤消息對話方塊中的「瀏覽」按鈕,然後指定 .msi 檔案。
  7. 如果你無法更新,請先從控制面板卸載舊的版本,然后重新啟動 Windows。確保 EmEditor 的安裝資料夾是空的 (通常是 C:\Program Files\EmEditor or %LOCALAPPDATA%\Programs\EmEditor),然后安裝新的版本
  8. 用 Windows 更新疑難排解工具來檢視 Windows 系統。(Windows 10Windows 8.1 或之前的版本)
  9. Microsoft Fix it 工具來檢查 Windows 安裝程式的系統。
  10. 在作為管理員帳戶運行的命令提示中用 Chkdsk 命令來檢查硬盤。這個過程可能要花幾個小時。
  11. 在作為管理員帳戶運行的命令提示中用 sfc /SCANNOW 命令檢查系統這個過程可能要花幾個小時。
  12. Windows 系統還原也許能把你的電腦設定還原到一個更早的日期。
  13. 如果因權限問題無法卸載 EmEditor,請嘗試創建一個管理賬戶,然后用新賬戶卸載。
  14. GeekUninstaller (freeware)Revo Uninstaller (freeware) 也許能夠幫你卸載一個舊版。
  15. 如果「檢查更新」命令無法運行,請到說明功能表下選擇「自訂更新檢查程式」,然后確保指定的下載資料夾是可寫的。預設的資料夾是 C:\ProgramData\Emurasoft\EmEditor\updates。
  16. 當更新 EmEditor 時,如果必須重啟一個系統,請在更新 EmEditor 之前關閉所有應用程式。特別是 Brother 控制中心 (BrCtrlCntr.exe),如果你安裝 Brother 列印機的話。這個應用程式可能會打開 EmEditor 資料夾,因此請到工具列的通知區域上關閉該控制中心。如果還是無法執行更新,請用處理序總管搜尋任何 EmEditor 安裝資料夾的開啟的控制代碼當被提示系統重啟時。
  17. 要報告安裝過程中出現的問題,請用 “/L*V log.txt” 運行安裝程式。例如,如果安裝程式是 emed64_15.7.0.exe,請運行 “emed64_15.7.0.exe /L*V log.txt”。如果要安裝到整臺電腦上,你必需有管理員權限來運行命令提示。要報告卸載過程中出現的問題,請運行與你想要用 “/L*V log.txt” 卸載的想對應版本的安裝程式。壓縮記錄檔 “log.txt”,然后電郵到技術支持 tech at emurasoft.com。
  18. 如果在安裝或啟動 EmEditor 期間,出現缺少「eeupdate.exe」的報告,則防毒軟體似乎在安裝或啟動 EmEditor 時刪除了 eeupdate.exe 檔案。請在安裝 EmEditor 時考慮停用防毒軟體,或將安裝檔案添加到防毒軟體的例外清單中。如果這不起作用,則可以在不複製 eeupdate.exe 的情況下安裝 EmEditor。為此,請在安裝時選擇「自訂」安裝,在「自訂安裝」屏幕中,展開「程式捷徑和關聯」,然後停用「檢查更新」。或者,您可以在 HKEY_LOCAL_MACHINE\SOFTWARE\EmSoft\EmEditor v3\Common key 中將「CheckUpdates」值創建為 REG_DWORD,並將其分配為 0。以上兩種方法都將完全停用更新檢查器,並且不會再搜索 eeupdate.exe。
  19. 如果出現「未標示為進行中時呼叫 RunScript。」消息,請檢查在 C:\Windows\Temp 資料夾中是否包含可寫權限。
  20. 如果在沒有連接網際網路的 PC 上運行 EmEditor,可能會遇到以下問題:

    – 當嘗試啟動 EmEditor 時出現一個警告對話方塊「無法驗證程式檔案的數位簽章」。
    – 無法驗證 EmEditor 檔案(例如 emeditor.exe 和 .msi 安裝程式)的數位簽章。
    – EmEditor 的啟動速度變慢。

    在這種情況下,請在運行 EmEditor 或驗證程式檔案的數位簽章時連接網際網路。 建立網路連接後,無需連接網際網路就可以繼續使用 EmEditor。

    如果無法連接到網路,請按照以下步驟安裝 Sectigo Code Signing Intermediate Certificate(Sectigo 程式碼簽名中繼憑證):

    1. 從連接互聯網的 PC 上,轉到 “How to Download & Install Sectigo Intermediate Certificates – RSA”

    2. 到 “Code Signing” 部分下載 “Standard Sectigo RSA Cod Signing CA”。

    3. 將下載的檔案複製到存在 EmEditor 檔案的目標離線 PC。

    4. 在目標 PC 上,右鍵單擊該檔案,選擇 “Install Certificate” (安裝憑證)。會出現 “Certificate Import Wizard” (憑證匯入精靈)。

    5. 按照精靈選擇 “Place all certificates in the following store” (將所有憑證放入以下存儲區), 單擊 “Browse”(瀏覽),然後選擇 “Intermediate Certification Authorities”(中繼憑證頒發機構)。單擊「下一步」匯入憑證。

    檢視 EmEditor 檔案(例如 emeditor.exe)的數位簽章,然後確認數位簽章沒問題就可以了。如果由於無法驗證根憑證讓數位簽章不 OK,請按照以下步驟安裝 Sectigo 根憑證:

    1. 從連接互聯網的 PC 轉到 “How to Download & Install Sectigo Intermediate Certificates – RSA”

    2. 到 “Root Certificates” 部分中下載 “SHA-2 Root: USERTrust RSA Certification Authority”。

    3. 將下載的檔案複製到目標 PC。

    4. 在目標 PC 上,右鍵單擊該檔案,然後選擇 “Install Certificate” (安裝憑證)。會出現 “Certificate Import Wizard” (憑證匯入精靈)。

    5. 按照精靈選擇 “Place all certificates in the following store” (將所有憑證放入以下存儲區), 單擊 “Browse”(瀏覽),然後選擇 “Intermediate Certification Authorities”(中繼憑證頒發機構)。單擊「下一步」匯入憑證。

安装

你能告訴我怎么安裝最新版本的EmEditor嗎?

你可以在EmEditor網頁上下載最新版本的編輯器。步驟如下:

1. 請關閉在運行的EmEditor系統匣圖示。(要改變系統匣圖示,你可以在任務列上右擊系統匣圖示,然后選擇“關閉系統匣圖示”)。

2. 從控制面板中先解除安裝前一版本的EmEditor。

3. 信息方塊會出現提示信息:“在完全解除安裝EmEditor前,你想要EmEditor的設置保持不變嗎?”如果你想要保留原來的設定,請選擇“是”。我們推薦你選擇“否”,除非你非常需要保留原來的設定以繼續完成你的工作。

4. 選擇藥下載的EmEditor版本和組態。你可以用下面的連結來下載:

下載 EmEditor

5. 當你點擊下載連結后,會出現一個檔案下載-安全警告對話方塊。

6.請點擊“執行”,然后會彈出一個網絡瀏覽器-安全警告 的對話方塊。

7. 選擇發布商:Emurasoft, Inc.

8. 請確保在電子簽名細節對話方塊中有“電子簽名可用”這個信息。如果這個信息沒有在對話方塊中顯示,那么下載的檔案可能被損壞了。這樣你就需要先清除臨時的網絡檔案(Temporary Internet files),再嘗試下載一次。點擊“確定”關閉對話方塊。

9. 請點擊“執行”鍵來開始安裝程式。你只需照著屏幕上出現的指令一步一步做就可以完成安裝了。

我現在使用的是舊版的EmEditor。我能不用解除安裝舊版的EmEditor就安裝新版本的EmEditor的嗎?

如果你使用的是EmEditor v3.00 或v3以後的版本,并且想要保持以前使用的EmEditor組態設定的話,你不需要解除安裝就可以覆蓋舊版。你可以在同一個目標資料夾中安裝最新的版本。但是你在安裝新版本之前,必須完全退出EmEditor程式,包括系統匣圖示也要關閉。如果你在安裝的過程中被要求重啟Windows,那你也需要重啟Windows.

如果你用的EmEditor版本在v3.00以前,也不想要保持以前使用的EmEditor組態設定的話,我們推薦你可以先完全解除安裝以前的版本,重新啟動計算機,然后再安裝新版本。具體步驟如下:
1. 選擇「開始」功能表中的“程式和功能”。從“解除安裝或更改程式”中選擇 EmEditor(或 EmEditor v3)。然后點擊“刪除”按鈕。
2. 當解除安裝完成后,重新啟動Windows。
3. 按螢幕指示,安裝新版本。

舊版和新版的EmEditor能在同一個計算機上共存嗎?

不能。舊版和新版的EmEditor不能在同一個計算機上共存。

在啟動或編輯中,如果EmEditor突然出故障了,怎么辦?

1. 如果你有安裝外掛,那么請在外掛資料夾中把所有外掛刪除,然后試著再運行一次EmEditor。
2. 如果程式還是不能正常運行,請到「開始」功能表中的“程式和功能”中解除安裝EmEditor。重啟計算機然后再次安裝EmEditor。
3. 如果EmEditor只在打開UTF-8或Unicode的檔案時出故障,請到編輯器中的“檢視”下拉功能表,選擇“字型”,并在“字型分類”清單中選擇“標準”,然后在“顯示字型”方塊旁按一下「變更」按鈕檢視是否選擇了合適的字型。

怎么才能永久性地移除EmEditor系統匣圖示?

請再次執行EmEditor的安裝程式并確保“添加系統匣圖示到工作列”的核取方塊沒有被勾選。這樣,你就不會再在工作列中看到EmEditor的系統匣圖示了。你不需要在執行EmEditor安裝程式前解除安裝EmEditor。如果操作不成功,請在Windows「開始」功能表中選擇“搜索”,然后搜索 “emeditor.lnk”檔案。這個檔案應該在啟動資料夾(Startup folder)中。要永久地刪除EmEditor系統匣圖示,你可以刪除這個檔案。

怎么能不用顯示對話方塊就安裝EmEditor?

在正常安裝的情況下,你會看到屏幕顯示對話方塊指示你完成一系列的安裝步驟。但是,如果你想把EmEditor安裝到公司,團體或個人使用的多臺電腦中時,你可以用一個批處理檔案或指令碼檔案讓電腦自動完成安裝并簡化安裝步驟。EmEditor使用Windows安裝程式來進行安裝,所以如果你不想看到對話方塊的話就可以把它們都屏蔽掉。

假設 EmEditor 的安裝檔案是 emed64_18.9.3.msi,請運行以下命令:

msiexec /i "(...path...)emed64_18.9.3.msi" /q MSIINSTALLPERUSER=1

這樣,EmEditor 在安裝時就不會出現任何對話方塊。如果您想變更預設設定的話,您也可以使用以下的這些選項:

MSIINSTALLPERUSER=1指定目前的使用者的安裝位每個使用者安裝。如果沒有指定,會預設為所有使用者安裝。
NOCHECKUPDATES=1停用定期到網絡上檢視最新版本 EmEditor 功能。
NOCONTEXTMENU=1停用添加一個快速鍵到檔案總管上的內容功能表中。
NODESKTOP=1停用添加一個快速鍵到桌面。
NOIEEDITOR=1停止把 EmEditor 添加至 IE 瀏覽器 HTML 編輯清單中。
NOIEVIEW=1停用在 IE 瀏覽器中用 EmEditor 檢視源程式碼的功能。
NOPATH=1停止把到 EmEditor 的路徑添加到 PATH 環境變量中。
NOSHORTCUT=1停止添加一個快速鍵到程式功能表中。
NOSKIP=1即使在更新時,也不跳過安裝程式屏幕。
NOTRAYICON=1停用系統匣圖示。
NOTXT=1停用文字檔案關聯。
REGNAME=”name”輸入授權使用者姓名。
REGKEY=xxxxxx輸入注冊金鑰。

如果您只想用注冊金鑰和授權者名字為目前的使用者安裝 EmEditor,請執行下列命令:

msiexec /i "emed64_18.9.3.msi" /q MSIINSTALLPERUSER=1 REGKEY=xxxxx REGNAME="John Doe"

如果您想用注冊金鑰和授權者名字為所有使用者安裝 EmEditor,請使用系統管理員權限執行命令:

msiexec /i "emed64_18.9.3.msi" /q REGKEY=xxxxx REGNAME="John Doe"

Windows安裝程式還有許多別的選項。具體信息,請執行:

msiexec /?

屏幕會顯示一系列可以操作的命令。

備注:
如果你要為所有使用者安裝 EmEditor,安裝程式一定要在管理員權限上運行,來避免「使用者帳戶控制」提示。例如,如果您要在命令提示符上運行安裝程式,您需要在按 SHIFT 鍵的同時右擊命令提示符圖標來打開命令提示符視窗,然后選擇以系統管理員身分執行。如果你僅為目前的使用者安裝 EmEditor,你必須指定 “MSIINSTALLPERUSER=1”

怎么變更安裝資料夾?

預設設定下,安裝新版 EmEditor 的資料夾與舊版的資料夾相同,如果是第一次安裝的話,預設的安裝資料夾是 %LocalAppData%\Programs\EmEditor(按每個使用者安裝 – 「只為我」)或 Program Files\EmEditor(按每臺計算機安裝 – 」每個人(所有使用者)「)。如果要變更安裝資料夾,請使用系統管理權限打開命令提示字元,然後用 NOSKIP 選項運行安裝程式。

例如,如果 EmEditor 安裝檔案是 emed64_18.9.3.msi,您想要把 EmEditor 安裝到另一資料夾中,請運行以下命令:

msiexec /i emed64_18.9.3.msi NOSKIP=1

這將使您有機會在安裝過程中選擇 “Custom”(自訂)按鈕,允許您變更安裝資料夾。

注意: 您不能變更安裝資料夾如果 EmEditor 是按每個使用者安裝。要變更安裝資料夾,您必須選擇為所有使用者安裝 EmEditor 選項。

不同版本的 EmEditor 無法同時存在在一臺電腦上。如果舊的版本已經安裝了,您必須先卸載舊的版本,或安裝新的版本到與舊版本相同的資料夾中。

怎么安裝EmEditor 語法檔案?

1. 在“工具”下拉單中,把滑鼠指向“選擇組態”。

2. 在清單的底部點擊“定義組態”。

3. 點擊「新增」按鈕,選擇“使用預設組態”然后點擊“確定”。

4. 輸入一個描述性名稱然后按輸入鍵(ENTER)。

5. 點擊一下「屬性」按鈕,然后選擇”亮顯(1)”標籤頁。

6. 點擊“導入”鍵,打開合適的語法檔案。如果「匯入」按鈕不可用,請檢查「啟用關鍵字亮顯」下的下拉清單方塊中是否選擇了「僅使用者定義的字串」或「使用者定義的字串和預設關鍵字」。

7. 最后,點擊「OK」關閉“組態屬性”對話方塊。

如果你想要啟用關聯的副檔名或指定一個副檔名的話,要先把EmEditor設定為與該組態相關聯,請進行下面幾步操作:

8. 到“工具”下拉單中,選擇“關聯組態”。

9. 點擊「新增」按鈕。

10. 用萬用字元輸入副檔名,比如  “*.ext”。

11. 選擇新設定的組態名稱。

我使用的是新版本的EmEditor。我能不解除安裝新版,就安裝一個舊的版本嗎?

不能。你必須先解除安裝新版,才能安裝舊版。如果不這樣做的話,會導致不同EmEditor版本的DLL檔案不相容。在你解除安裝新版本之前,你要先退出所有EmEditor視窗,包括系統匣圖示。在安裝過程中,你會被詢問是否要保留所有以前的設置。請選擇”Yes”,如果你想保留所有的自訂設置。如果Windows系統要求你在安裝過程中重啟電腦,你也需要重啟一下電腦。

在EmEditor Professional 安裝完成后,關聯的文字檔圖示沒有顯示為EmEditor的圖示。

EmEditor 專業版不再變更文字檔的圖示了。如果你想要用EmEditor的圖示來顯示所有的文字檔圖示,請到“工具”下拉單中選擇“自訂”,在打開的對話方塊中轉到“檔案”標籤頁上。點擊“與EmEditor關聯”。 如果清單中有“txt”圖示,請選擇“txt”圖示, 然后點擊「屬性按鈕,確認在“本檔案的事例圖示”下的檔案是emedres.dll檔案(通常顯示的檔案路徑是:C:\Program Files\EmEditor\emedres.dll)。也請確認在“當前圖示”中你有選擇與“txt”相匹配的圖示。如果清單中沒有任何圖示選項,請選擇“添加”來創建關聯圖示。你可以在“當前圖示”中選擇任何圖示,然后輸入”副檔名”和“檔案類型”,最后,點擊“確定”。之后,你會在”與EmEditor關聯”的清單中看到你添加的要與EmEditor關聯的圖示。

EmEditor 不運行。

如果你有安裝Trend Micro Internet Security系統,并且最新的安全更新系統已被安裝的話,EmEditor可能會出現啟動不了的問題。請解除安裝Trend Micro Internet Security ,或在桌面上清除Trend Micro Internet Security 的捷徑,問題就會解決。

怎么創建64位元便攜版本?

要創建64位元建置的便攜版, 你可以:

1. 從EmEditor網站上下載EmEditor Professional (64位元安裝程式)。

2. 右擊Windows圖示,在“執行”對話方塊中輸入下面的命令。一個子資料夾就會被創建。

msiexec /a "(…路徑…)emed64_18.9.3.msi"/qb TARGETDIR="目標路徑"
(假設安裝的程式檔案是emed64_18.9.3.msi)

3. 把整個資料夾復制到一個便攜的裝置中,例如USB 磁碟機中。

4. 在同一個資料夾中,創建一個空檔案,例如eeUselni.ini。

以上就可以完成創建EmEditor 64 位元建置的便攜版。

破解, KEYGEN, 序列

請詳見破解, KEYGEN, 序列頁。

解除安装

我在使用EmEditor 試用版本之后決定不購買。我怎么解除安裝?

關閉所有在運行的EmEditor程式(注意:EmEditor 說明也要關閉。如果你正在從說明上閱讀此頁,我們推薦你把步驟寫下來,或者也可以去我們的網站-支援常見問題集解除安裝中查看。) 點擊Windows操作系統中的「開始」功能表,選擇“程式和功能”,然后從“解除安裝或變更程式”中選擇 EmEditor,點擊「刪除」按鈕。然后按照EmEditor解除安裝對話方塊的指示完成解除安裝。我們推薦你在完成解除安裝后,重新啟動Windows。

我已經解除安裝了EmEditor。但是,當我雙擊打開一個檔案時,我的電腦還是在尋找EmEditor程式。由于EmEditor程式已不存在,我無法打開檔案,怎么辦?

如果你以前有把檔案與EmEditor關聯,那么這些關聯應該在你解除安裝EmEditor之后被還原。但是,如果你在別的應用程式中,比如檔案總管中,把檔案關聯到EmEditor,那你需要自己還原關聯設置。打開Windows檔案總管,找到一個你要打開的檔案,右擊此檔案,選擇“屬性”,在彈出的對話方塊中,找到“檔案類型”,按一下「變更」鍵,你就可以選擇要用哪種應用程式打開該檔案了。

在我解除安裝EmEditor之后,當我選擇在IE瀏覽器上的內容功能表中選擇“檢視源”后,為什么原始程式碼不顯示在記事本中?

一些比較早版本的EmEditor不能夠完全解除安裝注冊信息。你需要選擇「開始」功能表中的“執行”,然后輸入“RegEdit.exe”,在點擊「確定」鍵來啟用注冊表編輯器。請在注冊表編輯器中搜索HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor 然後刪除該項。

在解除安裝EmEditor之后,emedtray.exe 和 emedres.dll 檔案仍然在 C:/Program Files/EmEditor中,我要怎么刪除這些檔案?

當你解除安裝EmEditro之后,這些檔案應該就會被自動從你的電腦上刪除了。要手動刪除這些檔案,你首先要確認執行EmEditor的捷徑,也就是工作列上的EmEditor系統匣圖示是否已經被關閉了。
要永久刪除EmEditor的系統匣圖示的話,請參考下面的連結:

Q:怎么才能永久性地移除EmEditor系統匣圖示?

如果工作列上還是顯示EmEditor的系統匣圖示,請你先關閉這個圖示,然后刪除 emedtray.exe 和 emedres.dll 檔案。

我不能從控制台上的“解除安裝或變更程式”中解除安裝舊版的EmEditor, 我要怎么做?

如果你無法解除安裝一個舊的版本,請用“/L*V log.txt”指令來運行舊版的安裝程式,這樣就會為解除安裝該程式創建一個記錄檔(log file)

例如,如果安裝程式名是“emed64_14.3.1.exe”,請運行下面的指令:

emed64_14.3.1.exe /L*V log.txt

這個 log.txt 檔案可能含有非常有用的信息,比如為什么安裝程式停止工作。

注意:舊版的安裝程式能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 資料夾中找到。

如果你在解除安裝或安裝一個新的版本時,看到下面的對話方塊內容:

“你試圖使用的功能在一個不可用的CD-ROM或其它移動磁碟機上。請插入 ‘EmEditor Professional (…)’ 磁碟機并點擊確認。”

首先,請先找到舊版的安裝程式。用 “/extract” 把該安裝程式提取出來。例如,如果安裝程式是 “emed64_14.3.1.exe”,你可以運行下面的指令:

emed64_14.3.1.exe /extract

這將創建一個子資料夾。在這個資料夾中,你將會看到一個有著 “.msi” 副檔名的檔案,在我們舉的這個例子中,你會看到檔案名顯示為 “emed64_14.3.1.msi”。

當你解除安裝時,看到了以上所述的對話方塊內容,請點擊「瀏覽」按鈕,并指定上面的 .msi 檔案。繼續這個過程,你應該可以解除安裝舊版的EmEditor。

如果你不確定你需要哪一個 .msi 檔案,你可以查看 log.txt 檔案,應該會找到相關信息。

另外,如果當你從控制台解除安裝時解除安裝程式停止運行,請試試看用 GeekUninstaller (freeware)Revo Uninstaller (freeware) 來進行解除安裝。

如果你還是需要幫助的話,請把具體發生的情況寫下來,并和 log.txt 檔案一起發送到我們的技術支援部 tech@emurasoft.com。我們會儘快答覆你。

我想把 EmEditor 安裝到另一臺電腦上。是否有任何步驟要遵循?

您只需從一臺電腦上解除安裝 EmEditor,然後將 EmEditor 安裝到另一臺電腦上即可。沒有別的特殊步驟需要遵循。

我想從一臺電腦上解除安裝 EmEditor,並將 EmEditor 安裝到另一臺電腦上。我該如何轉移設定?

如果要從舊電腦匯出設定,並將其匯入新電腦:

1. 在舊電腦上,選擇「工具」功能表上的「匯入和匯出」,然後選擇「匯出所有設定到一個登錄檔案中」。從 Windows 設定中選擇應用程式,然後選擇要解除安裝的 EmEditor。

2. 將所有匯出的檔案和子資料夾複製到新電腦。

3. 在新電腦上,安裝 EmEditor,在「工具」功能表上選擇「匯入和匯出」,然後選擇「從一個登錄檔案中匯入所有設定」。

檔案

當我試著不用副檔名來儲存一個檔案時,"txt"會被自動添加到這個檔案名中。我怎么阻止副檔名被自動添加到檔案名中的情況?

在檔案名前后用雙引號(“”)引起來,就能防止自動添加副檔名。例如,如果你輸入的檔案名是”File”,那么檔案的名稱就是File,而不是File.txt。

當打開一個檔案時,EmEditor偵測到檔案的當前編碼是"Western European",即使它是一個簡體中文(GB2312)檔案。

在“組態屬性”的“檔案”標籤頁,請不要勾選“全部檢測”, 編碼檢測會出現錯誤,特別是小檔案。

怎么能同時關閉所有視窗?

按下SHIFT鍵,然后同時點擊編輯器右上角紅色框框中的”X”。另外,你也可以這樣做:

  • 按ALT + SHIFT + F4
  • 按ALT + SHIFT + X
  • 檔案下拉單中選擇關閉,然后再按一下SHIFT鍵
  • 在工具列上添加「關閉全部」按鈕,然后點擊該按鈕。
  • 點擊系統匣圖示,然后在功能表中選擇“全部關閉”。

怎么能讓“打開”對話方塊一直顯示一個指定的資料夾?

選擇工具功能表下的“自訂”,然后在“檔案”索引標籤上勾選“記住最后打開的資料夾”。

另外,你也可以右擊EmEditor捷徑,打開屬性。在“目標”(Target)文字方塊中的路徑后加/cd。例如,如果EmEditor的安裝資料夾是“C:\Program Files\EmEditor”,那么請輸入“C:\Program Files\EmEditor\emeditor.exe” /cd。然後在起始位置(Start in)文字方塊中輸入你要打開的資料夾的路徑。

怎么能保持一個空檔案?

選擇工具下拉單中的“當前組態屬性”,然后在“檔案”標籤頁上點擊「儲存中…」,在彈出的對話方塊中清除對“當儲存時刪除空檔案”的勾選。

列印出來的字型太小,怎么辦?

請選擇工具下拉單中的“當前組態屬性”,在“列印”標籤頁上選擇「字型…」,然后你就能更改字型和大小了。

當讀取Macintosh文字檔時,一些字元無法正常顯示。怎樣才能正常地讀取Macintosh文字檔呢?

Macintosh 與Windows 系統使用的程式碼頁稍有不同。在Windows 2000/XP/2003/Vista 中,Macintosh 的程式碼頁已經安裝了,你能輕松地把Macintosh 文字檔轉換成Windows 文字檔。首先,在工具下拉單中選擇“定義編碼”。在彈出的對話方塊中,點擊“新增”,然后選擇Macintosh 編碼,例如“10001 (MAC – Japanese)”。在選擇一個適當的字型類別,例如Japanese(日文)。點擊“確定”,儲存設定。

接著,到檔案下拉單中,選擇“打開…”,在“編碼”下拉清單中選擇你剛剛設置的編碼,然后你就可以正常讀取Macintosh檔案了。

在Windows 98/Me中,沒有安裝Macintosh的程式碼頁,所以你無法正常讀取有特殊字元的Macintosh檔案,因为Windows程式碼頁无法讀取这些檔案。

在一個網際網絡上使用一個共享資料夾,可以阻止別的使用者更改我已開啟的并且正在編輯的檔案嗎?

是的。你可以到組態屬性的“檔案”標籤頁上,在“被其他程式變更時”旁的下拉清單中選擇“保持鎖定”。這樣,其他使用者就不能打開這個檔案了。但是他們能在你關閉檔案之后,編輯并儲存變更。

怎么能黑白列印我的檔案?

請到“當前組態屬性”中的“列印”標籤頁,勾選“忽略顏色與底線”核取方塊。要列印彩色時,請不要勾選該選取方塊。

怎么能加速打開一個大檔案呢?

一些組態的設定會降低程式運行的速度。請檢查以下幾點:

  • 打開“當前組態屬性”對話方塊,到“一般”標籤頁上,如果“自動換行”清單下的選項不是“不換行”的話,那么EmEditor的速度可能會變慢,因為它要計算哪里要換行。所以,當你要打開大檔案時,請選擇“不換行“指令。

怎么能把一段中文(或日文、韓文等)的Word文檔貼上到EmEditor中并把它儲存為一個文字檔呢?

如果Windows不能正常顯示日文,韓文或中文字型,那么你需要到控制台,選擇“時鐘,語言和區域”,點擊“語言”索引標籤,然后安裝東亞語言檔案

打開你的Word文檔,選取你要復制的文字,然后按一下 CTRL+C 把文字復制到剪貼簿中。

開啟一個新的EmEditor視窗后,按一下 CTRL+V 來把剪貼簿內容貼到EmEditor視窗中。在EmEditor中顯示的文字應該是正常的,但如果顯示不正常,請從“檢視”下拉單中的“字型類別”中選擇文字的語言類別。如果還是不能正常顯示,請到“檢視”下拉單中的“字型”對話方塊中點擊顯示字型旁的“變更”按鈕,然后從清單中選擇一個合適的字型,比如中文是Simsun。

要儲存文檔時,請選擇「另存新檔」,確保你在編碼清單中選擇的是Unicode 或是UTF-8。你也可以選擇一個區域設置特定的編碼,例如繁體中文。

怎么用西歐(Western European)而不是UTF-8打開一個XML檔案?

如果一個XML檔案是作為Unicode被打開的,你可以到“當前組態屬性”中,選擇“檔案”索引標籤,然后檢視“檔案打開時的編碼”旁的下拉清單。如果被選擇的是“Unicode”,請你把它改為“系統預設”。如果“檢測 HTML/XML 字元”核取方塊被勾選了,一個“encoding=” 的指令會在一個XML檔案中被搜尋。如果這個指令被找到了,EmEditor會使用這個指定的編碼。要注意的是,為目前打開的檔案所指定的編碼與新增檔案或正在儲存的檔案所指定的編碼是不同的。

怎么用西歐(Western European)而不是UTF-8來新增Java檔案或XML檔案?

在預設情況下,Java檔案和XML檔案會作為UTF-8打開,當你從檔案下拉單中選擇新增JavaXML編碼檔案時。你可以變更組態屬性設定來改變這一預設的設置。具體步驟是:組態屬性->“檔案”索引標籤->「新增檔案…」->”編碼”下拉清單中選擇“系統預設”。要注意的是新增檔案所設的編碼可能會與正在打開的或正在儲存的檔案不同。

EmEditor被指定為另一個應用程式的外部文字編輯器。為什么在EmEditor中做的改變沒有在這個應用程式中顯現出來?

如果EmEditor被設定為另一個應用程式(例如郵件用戶端)的外部文字編輯器,并且這個應用程式監控著EmEditor的操作,這個程式很有可能不會反映用EmEditor儲存并修改的內容。要解決這個問題,請用/sp(分離)選項在單獨的進程中啟動EmEditor (具體操作方式是:右擊Windows「開始」功能表->點擊“執行”->輸入”emeditor /sp”)。這樣的話,EmEditor程式就會在一個單獨的進程中被運行。

我能打開GB18030的檔案嗎?

是的。具體操作如下:

工具->定義編碼->新增->編碼->簡體中文(GB18030)

當您要打開一個檔案時,請確認您選擇了這個新定義的編碼。

怎么能用命令列轉換檔案編碼?

你可以參考使用下面的命令列選項:
/cp Encoding —— 打開檔案時,指定編碼方式。
/cps Encoding —— 儲存檔案時,指定編碼方式。
/sa “DestFile” —— 變換編碼后,另存新檔并重命名。
ss+ —— 變換編碼后,用Unicode簽名(BOM)儲存檔案。
ss- —— 變換編碼后,不用Unicode簽名(BOM)儲存檔案。

比如,如果你想要把一個檔案(Chinese.txt)從繁體中文(big5)轉換成UTF-8,并且想把檔案重命名為utf8Chinese,你可以使用如下所示的語法:
emeditor.exe “Chinese.txt” /cp 950 /cps 65001 /ss- /sa “utf8Chinese.txt”

請參考以下兩個連結來編寫命令列:
編碼常數
如何使用命令列選項

怎么能指定用EmEidtor打開特定副檔名的檔案?

工具->自訂->“檔案”索引標籤->與EmEditor關聯->添加要用EmEditor打開的檔案副檔名

之后,你只要在檔案總管中雙擊含有添加的副檔名的檔案,就能用EmEditor打開有這些類型的檔案。

怎么能以獨占方式打開檔案?

工具->所有組態的屬性(如果你已經打開了檔案,請選擇“當前組態屬性”)-> “檔案”索引標籤->在“被其他程式變更時”旁,選擇“保持鎖定”

當我要檢視一個當地的HTML檔案并保存該檔案時,IE瀏覽器突然終止了,怎么辦?

在Windows XP 上,這個情況會出現是因為在“組態屬性”中的“備份”索引標籤上,“使用回收站進行備份”的核取方塊被勾選了。所以,在用IE瀏覽器檢視HTML檔案時,請確認該核取方塊沒有被勾選。

在檔案前的3個無效字元是什么?

檔案頂端的3個無效字元是UTF-8檔案的字節順序標記(BOM)。在預設情況下,Java檔案是作為含有BOM的UTF-8檔案被創建的。你可以通過取消勾選“添加一個Unicode簽名(BOM)”核取方塊來變更這個預設的設置。

編輯

怎么用鍵盤選取文字?

按下F8切換到正常選取模式。按 CTRL + F8 來選取整行;按 SHIFT + CTRL + F8 則變成方塊選取(編輯器中稱作“相黏垂直選擇”)模式。要改變鍵盤設定,請到“工具”下的“當前組態屬性”中選擇“鍵盤”索引標籤,對鍵盤進行變更或自訂鍵盤設定。

可以插入控制字元,例如換頁符嗎?

要在EmEditor 中插入控制字元,操作如下:

編輯->進階->插入特殊字元

另一種方法是你可以用 CTRL (+ SHIFT) 加對應的鍵來輸入你要的字元。但是,前提是這個組合沒有被定義成別的捷徑,并且,請確認在組態屬性中的“一般”索引標籤上,“允許插入控制字元”核取方塊已勾選。

文字內容無法被正常貼到EmEditor上。這段文字是從另一個應用程式中復制過來的,比如Netscape Navigator。

一些應用程式在把文字從ANSI轉碼到Unicode時,會出現一些困難,特別是Netscape Navigator。所以,這時我們不能用一般的“貼上”命令來獲取文字。請按如下步驟操作:

工具-> 所有命令 -> 編輯 -> 貼上 -> 貼上為系統預設編碼

你也可以這樣做:

工具-> 當前組態屬性 -> 一般 -> 勾選“總是作為ANSI貼上”

怎么插入特殊字元?

要在EmEditor 中插入控制字元,操作如下:

編輯->進階->插入特殊字元

要檢查你想要插入的Unicode字元程式碼,請參考這個連結:拉丁擴充字元參考
如果你的Windows系統有組態“字元對應表”,你也可以通過單擊「開始」按鈕,打開“字元映射表”來檢查字元。(或在搜索方塊中,鍵入“字元對應表”,然后在結果清單中單擊符合的結果)。你可能需要調整字型,使檔案能正常顯示。

同樣,請參考“插入特殊字元”來檢視特殊字元的鍵盤捷徑。

怎么選取一整列的文字?

要方塊選取文字,請使用滑鼠選取加ALT鍵的方式,或者也可以按SHIFT + CTRL + F8,切換到方塊選取模式(EmEditor中稱為“相黏垂直模式”)。

我要去哪里下載微軟Global IME (輸入法編輯器)?

微軟Global IME 不是必需的,因為其他語言的IME可以到“控制台”中添加。(「開始」按鈕 -> (設置 ->) 控制台 -> 時鐘,語言和區域)。

怎么用復原命令一一刪除插入的字串?

預設情況下,當你點擊「編集」按鈕時,一整個插入的字串會被刪除。例如,當你輸入”abc”時,點擊「編集」后,整個”abc”字串將被刪除。但是,如果你需要點擊「編集」后只刪除一個字元,”c”,你可以進行如下操作:

工具-> 自訂 -> 編集 -> 勾選“逐格編集” (你可能需要重啟EmEditor)。

怎么把行按字母或數字進行排序?

你可以選擇“按字母升序模式排列”,“按字母降序模式排列”,“按數字升序模式排列”,“按數字降序模式排列”命令把行重新排序。這些命令在“編輯”下拉單中的“分開的數值/排序”里。

怎么能檢查拼字?

在EmEditor專業版v10后的版本中,你可以不用使用任何外掛就能檢查拼字。在EmEditor的內容功能表中(右鍵功能表),選擇進行“拼字檢查”。如果無法看到這一選項,請到“工具”下的“自訂功能表”中選擇“內容功能表”,然后按「重置」按鈕。EmEditor 預設安裝了英語(美國)字典。其他語言的字典請到extensions.OpenOffice.org(http://extensions.openoffice.org/)中下載。在下載一個字典檔案后,請把副檔名從.oxt改為.zip,然后解壓縮這個zip檔案,并且把 *.dic和 *.aff 檔案復制到EmEditor安裝資料夾中的Dictionaries(字典)子資料夾中(通常在 C:\Program Files\EmEditor\Dictionaries)。

怎么給特殊字元設置捷徑?

許多特殊字元已經有預設的捷徑了。請點擊下面的連結檢視已設置的一些特殊字元的捷徑:

插入特殊字元

除此之外,你可以用巨集給任何你常用到的字元設置捷徑。例如,你想要用一個捷徑插入ä,你可以編寫一個巨集(這個例子中,我們要用JavaScript編寫):

document.selection.Text=”ä”;

然后把這個檔案儲存為InsertA.jsee。在“巨集”下拉單中點擊“選擇…”,并打開InsertA.jsee。當執行這個巨集時,EmEditor便會自動插入這個字元。你只需要打開“工具”下的“組態屬性”,到“鍵盤”索引標籤上,在“類別”下拉清單中選擇“我的巨集”,并自訂一個捷徑給這個巨集,設定完成后,你就能用你自訂的捷徑來插入這個特殊字元了。

“尋找配對的括號”這個命令不起作用。怎么才能啟用這個命令?

請到“組態屬性”中的“亮顯(2)”索引標籤上,檢查是否所有的“括號對”清單中的選項都被勾選了。然后你可以用 CTRL+] 在比對的括號之間跳轉。

當一個大檔案被打開時,排序命令將不能啟用。什么情況下會禁用排序命令?

兩種情況下會禁用排序命令。

1.在“自訂”對話方塊中的“進階”索引標籤上,“使用臨時檔案的最小檔案大小”一定要大于你要打開排序的檔案大小。

2.如果你使用的是32位元版本的EmEditor,在注冊表編輯器中,請找到下面的一項:

HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3\Common

然后把一個新的REG_DWORD值,MaxReserveBits,設置為Decimal 24(十進位24)或Hexadecimal 0×18(十六進位 0×18。32位元EmEditor的預設值是Decimal 20,64位元EmEditor的預設值是Decimal 24。

這些值指定了EmEditor可以排序的最多行數。您不能指定比24大的值,如果指定值是24,那么理論上,允許的最多行數應該是 16777216。然而,如果操作系統無法分配一個大的記憶體,那么實際允許的最多行數可能會變少。在這種情況下,您可能需要重新啟動Windows并且在您再次嘗試之前只運行EmEditor。如果您在使用的是64位元建置的EmEditor,它的預設值就是Decimal 24,因此不必要設置注冊表中的值。

有沒有可以讓游標“撤消”和“重做”的命令?

有,它們被稱為“後退”和“前進”。在預設的鍵盤捷徑中,ALT + LEFT:後退; ALT + RIGHT:前進。有個這兩個鍵,你可以將游標後退到前一個位置,或前進到下一個位置。
這兩個命令有對應的工具列按鈕,可以通過“自訂工具列”被添加到EmEditor的工具列上。

貼上命令不起作用,怎么辦?

請檢查一下你的殺毒軟體。有時候,殺毒軟體會阻止應用程式訪問剪貼簿。如果是這樣的話,你必須要明確地把EmEditor排除在阻止訪問剪貼簿的應用程式之外。

CSV

如何停用 CSV 偵測?

在「工具」功能表上選擇「目前的組態屬性」,選擇「檔案」頁面,然後取消勾選「要偵測的 CSV 檔案」清單方塊中的所有核取方塊。

如何啟用 TSV( Tab 分隔)檔案偵測?

在「工具」功能表上選擇「目前的組態屬性」,選擇「檔案」頁面,然後在「要偵測的 CSV 檔案」清單方塊中勾選「 Tab 分隔」核取方塊。

打開 CSV 檔案時如何停用調整欄位置?

在「工具」功能表上選擇「自訂」,選擇「CSV」頁面,然後取消勾選「自動調節分隔符號位置」核取方塊。

如何按特定的數字範圍篩選欄?

在「篩選」工具列中,單擊「[ , ]」(使用數字範圍)按鈕,然後在出現「輸入數字範圍」對話方塊時輸入數字範圍。如果未出現此對話方塊,請在「篩選」工具列中以「[最小,最大]」格式輸入數字範圍,然後按歸位鍵。

如何將欄中的數字舍入到小數點後 2 位?

選擇要對數字進行舍入的整欄。在「搜索」功能表上選擇「取代」(或按 CTRL + H)以顯示「取代」對話方塊。單擊「數字範圍」選項按鈕。出現「輸入數字範圍」對話方塊後,清除「僅整數值」選項,將「最小值」和「最大」欄位留空,單擊「確定」。確保在「尋找」欄位中設定「[,]」。在取代為欄位中,輸入「\J parseFloat( \0 ).toFixed(2)」。確保啟用「僅限於選區內」選項,然後單擊「全部取代」按鈕。

如何僅顯示欄中的空儲存格?

右鍵單擊空儲存格,然後從內容功能表中選擇「在欄中篩選」。

搜索

怎么用“尋找”對話方塊來顯示以前搜索過的字串,而不是在游標處的單詞?

在“尋找”下拉清單的右面有一個「>」按鈕。點擊這個按鈕顯示下拉功能表,然后選擇“自訂”。然后按一下「>」,選擇“儲存為預設”。

怎么把“尋找”文字方塊中所有以前搜索過的字詞都清除?

工具 -> 自訂 -> “歷史記錄”索引標籤  -> 「清除歷史記錄」

怎么能在行的開頭或末尾搜索一個字?

當你在“尋找”對話方塊中勾選了“使用規則運算式”后,行的開頭可以用 “^”來表示,而行的末尾可以用 “$” 來表示。所以,要在行的開頭部分尋找,請在“尋找”文字方塊內輸入“^xxxxx”;要在行的末尾部分尋找,請輸入“$xxxxx”。

你還可以勾選“使用逸出序列”,這樣你就能用“\n”來表示新的一行。當你要在行的開頭部分尋找,你可以輸入“\nxxxxx”;當你要在行的末尾部分尋找時,可以輸入“xxxxx\n”。

為什么EmEditor不亮顯多行字串?

為了增加程式的性能,EmEditor 的設計是一行一行亮顯字串,而不是亮顯包含新行的字串。

尋找/取代對話方塊太大了。

你可以把滑鼠移到尋找/取代對話方塊的右下角來調整對話方塊的大小。

怎么在尋找/取代對話方塊中把多行字串作為要搜索的字串?

在“尋找”下拉清單的右邊有一個「>」按鈕。點擊這個按鈕,選擇“多行”。然后,你可以把滑鼠移到對話方塊的右下角使對話方塊變大,讓你能輸入多行的字串。要換行輸入時,請使用CTRL + ENTER (輸入鍵)來換行。

檢視

原來游標的形狀像這樣“|”,但現在它變成了一個實心的長方形狀。當我打字時,它不是輸入文字,而是改寫以前存在的檔案。怎么辦?

發生這種情況是因為你的EmEditor中的“覆寫”模式被啟用了。請按一下鍵盤上的“Insert”鍵來切換“插入/覆寫模式”。

怎么用記號標示單字節的空格?

到“組態屬性”下的“標記”索引標籤,勾選“顯示空格”核取方塊。

當我用預設設置顯示一個檔案時,檔案不可讀;如果我從“檢視”下的“字型分類”選項中選擇另一個字元集,檔案看起來更糟糕。但是,如果我在打開檔案時選擇一個合適的編碼,檔案則能正常顯示。這是怎么一回事?

EmEditor的內部處理編碼是Unicode。當你打開一個ANSI檔案時,EmEditor可以把ANSI文字轉換為Unicode文字。當你要打開一個檔案時,你應該在“打開”對話方塊中選擇一個編碼,如果你不這樣做,EmEditor會用系統預設編碼來打開檔案。所以,要用一個不同的編碼來打開檔案,你需要指定打開該檔案的編碼。如果你已經用一種編碼打開了檔案,你可以去“檔案”功能表下的“重新載入”來選擇不同的編碼重新載入檔案。

我什么時候要使用“檢視”功能表下的“字型分類”?

EmEditor無法從Unicode檔案中檢測語言。你必須在“檢視”功能表下的“字型分類”中選擇一個合適的類別來顯示非系統預設的字型集。當創建一個新檔案時,如果你要使用的語言是非系統預設的字型集,你也需要去“檢視”功能表下变更字型類別。

在從一個頁面到另一個頁面時,怎么才能讓編輯器顯示連續的行號?我以前沒有遇到過這個問題,但是現在我的組態好像被變更了。

在“當前組態屬性”對話方塊中的“一般”索引標籤上,請清除勾選“顯示頁碼”核取方塊。

什么是邏輯坐標和顯示坐標?什么是一個邏輯行?

邏輯坐標指的是一個文檔中的坐標,不管這個文檔是用哪一種換行模式。在邏輯坐標中,因為換行而進行的輸入鍵不算在內。邏輯行指的是一個文檔中行的總數減去換行產生的行。顯示坐標,則包括換行后的行。

我在EmEditor視窗的左邊有顯示行號,但是,當一個邏輯行換行時,我不想讓行號也隨之遞增。我該怎么做?

當前組態屬性 -> 一般 -> 在“行列顯示”下的下拉清單中選擇“邏輯坐標”中的一個。

我不喜歡新的像玩具一樣的Windows XP 樣式工具列。能顯示舊的工具列按鈕嗎?

可以。工具 -> 自訂工具列 -> 勾選“16色”。

我能把工作列上的系統匣圖示用我最喜歡的圖示來顯示嗎?

可以。到注冊表編輯器(RegEdit.exe)中,找到:HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3\Common ; 創建一個TrayIconFile值并把它定位REG_SZ, 然后設置圖示檔案路徑,把TrayIconIndex 值設為REG_DWORD,并設置圖示索引。

怎么能用不同的顏色再次亮顯以前搜索過的字串?

當前組態屬性 -> 顯示 -> 在“搜索亮顯”旁的編輯方塊中更改你想要醒目顯示的搜索次數;要讓不同的搜索內容顯示不同的亮顯顏色,請把“指定部分”下的清單方塊拉到最底行,選擇“搜索字串(1),(2)…,然后選擇“背景顏色”或“文字顏色”來顯示不同的搜索字串。

怎么在游標處顯示底線?

當前組態屬性 -> 捲動 -> 勾選“水平線”

怎么在顯示URL時,不用在特定的字元處斷開?

當前組態屬性 -> 連結 -> 在“識別這些字元”文字方塊中填入你不想要斷開URL的字元(例如“,”逗號)。

游標豎線很窄,能讓它變寬嗎?

在Windows Vista中,你可以到“控制台”中選擇“優化視覺顯示”,把“設置閃爍游標的粗細”的數字調大。

在Windows XP中,你可以到“控制台”中選擇“輔助功能選項”,然后去“顯示”索引標籤,在“游標選項”下調整“寬度”。

怎么統計選取的文字字數?

你可以使用“計數”外掛,這個外掛在EmEditor專業版v6之后就成為EmEditor專業版的內置外掛之一。如果你使用的是EmEditor標準版,請到資源庫下載這個外掛。

怎么用Unicode字元解碼數字字元參考("&#xx")?

請按照以下的步驟操作:
編輯 -> 編碼/解碼已選定的文字 -> 將HTML/XML字元參考轉換為Unicode

怎么知道每行的換行方式(例如,CR,LF,CR+LF)?

請在“自訂”對話方塊中的“狀態列”索引標籤上勾選“游標處字元的字元程式碼”。當游標在任一行的行末處時,你會看到EmEditor視窗中的狀態列上分別顯示0D+0A (CR+LF),或0D(僅僅CR)或0A(僅僅LF)。
另外,你可以到組態屬性中的“標記”索引標籤上勾選“使用不同的標記來顯示CR與LF”來標示不同的換行方式。由于在EmEditor中每一行都可以有不同的換行方式,如果你勾選了這個選項,EmEditor會顯示每一行的換行方式。

怎么把「標記」按鈕添加到工具列上?

請雙擊工具列(含有最基本的工具按鈕的那一個)的邊框。在快顯的“自訂工具列”對話方塊中選擇「標記」按鈕,然后“添加”。另外,你也可以到“工具”功能表下選擇“自訂工具列”,雙擊“工具列1”,在快顯的對話方塊中添加「標記」按鈕。

怎么顯示行號?

當前組態屬性 -> 一般 -> 勾選“顯示行號”

在XHTML和HTML文檔中,XML檔案,標籤文字和游標處匹配的標籤被醒目顯示。怎么終止這個行為?

請按以下步驟操作:
當前組態屬性 -> 亮顯(2) -> 清除勾選“亮顯匹配標籤”

怎么更改使用者介面語言?

自訂 -> 語言 -> 選擇你要使用的介面語言

自訂

當我點擊郵件地址時,怎么用我最喜歡的e-mail軟體發送郵件?

要讓你想要使用的e-mail程式成為EmEditor預設的e-mail軟體,請到“控制台”中的“Internet選項”去,選擇“程式”索引標籤,你可以在“設置預設程式”中設置你想要預設使用的e-mail程式。
如果你的電腦系統不支持以上的操作,你可以到檔案總管中的“檢視”功能表下選擇“選項”,然后點擊“檔案類型”索引標籤,更改”URL:Mail To Protocol”的設定。請雙擊“打開”鍵,并在“用于執行操作的應用程式:”列中輸入你要使用的e-mail軟體路徑及選項。你可以參考e-mail程式中的說明來輸入軟體路徑和相關選項。要注意的是,一些e-mail程式并不支持此功能。

點擊URL時能用我喜歡的網際網路瀏覽器打開網頁連結嗎?

當你安裝了另一個瀏覽器時,你會被詢問是否要把這個瀏覽器設置為預設瀏覽器。然后,你在EmEditor中點擊任何URL便會立即啟動你設置為預設的瀏覽器。

怎么讓插入的日期年份是4位數?

請到“控制台”中的“區域設置”設定日期的顯示方式。這與記事本(Notepad)中的操作是一樣的。

怎么把組態屬性中的設定復制到另一臺電腦上?

如果你使用的是EmEditor v5 或v5后的版本,你可以到“工具”功能表下的“導入和導出”中,根據自己的需求選擇導出當前設置的方式,然后在另一臺電腦上導入設置。
對于EmEditor v5 之前的版本,你需要在注冊表編輯器(Regedit.exe)中寫入HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3 檔案,然后把檔案復制到另一臺電腦上,并在注冊表編輯器中讀取檔案。你可能需要在“屬性”中自己重命名資料夾。

為什么沒有ASP組態?

ASP語法被包括在HTML組態中,并且根據VBScript或JavaScript組態的設定,嵌入的指令碼(通常用VBScript或 JavaScript編寫)也會被醒目顯示。

關于組態屬性中“亮顯(2)”索引標籤上的“特殊語法”的選項,什么時候適合選擇“HTML”,什么時候要選擇“HTML-嵌入”?

當指定指令碼語言HTML標籤(SCRIPT type=…)出現在HTML文檔中時,你可以選擇“HTML”。“HTML”的選項同時也適合ASP檔案,包括以%符合開始的指令碼,諸如 VBScript, Javascript, PerlScript, CSS等等。當你使用在#ScriptBegin中指定的標示指令碼語言開頭的字串時,例如PHP或JSP中的%和?,“HTML-嵌入”的特殊語法會比較適合。

當儲存HTML或XML檔案時,EmEditor能夠把Unicode字元編碼為“數字字元引用”(NCR-如 &#xx)嗎?

是的。在組態屬性中的“檔案”索引標籤上,點擊「儲存中」,然后勾選“把Unicode儲存為HTML/XML字元參考”。你也可以勾選“使用命名實體參考”如果你想要儲存諸如像©的命名實體參考。如果你的組態是HTML和XML組態,這些核取方塊都會被預設勾選。但是,當加載HTML 或 XML 檔案時,EmEditor目前不能把NCR解碼或顯示為Unicode字元。

在“檔案”功能表下“重新載入”的子功能表中,除了相同編碼,系統預設,UTF-16LE,UTF-16BE,UTF-8,和UTF-7之外,沒有其他編碼可用。我怎么添加更多的編碼頁?

如果你沒有適當地安裝EmEditor,只是把emeditor.exe檔案從一臺電腦復制到另一臺電腦并且嘗試運行程式,那么一些系統內設置的編碼可能不會在EmEditor復制版中顯示。如果你使用的是Windows NT/2000/XP,要安裝另外的編碼,你可以作為進階使用者(Power User)或管理員身份登入,并選擇在“工具”功能表下,選擇“定義編碼”,然后點擊「重置」。編碼的可用性取決于你安裝在Windows中的語言系統檔案。如果你無法在EmEditor中找到你要的那種編碼,你可以到“控制台”中的“區域和語言選項”安裝額外的語言檔案。當語言系統檔案安裝到你的Windows系統中后,再次到EmEditor中選擇“定義編碼”,點擊「重置」。

在更新EmEditor后,怎么把新命令添加到一個功能表中或添加新的捷徑?

如果新命令沒有在功能表中顯示,請到“工具”功能表下的“自訂功能表”中,點擊「重置」按鈕,還原功能表的預設設置。要添加新的命令捷徑,請到“所有組態屬性”中的“鍵盤”索引標籤上點擊「重置」。

怎么定義兩次按鍵的鍵盤快捷方式?

你可以通過整合使用者功能表特性和鍵盤對應特性來定義兩次按鍵的鍵盤捷徑。通過定義使用者功能表(1),CTRL+K 已經被預先設置為第一個兩次按鍵的鍵盤捷徑。

一些系統預先定義的捷徑包括:
CTRL+K, K 切換書籤
CTRL+K, N 當前文檔中的下一個書籤
CTRL+K, P 當前文檔中的上一個書籤
CTRL+K, L 清除當前文檔中的所有書籤
CTRL+K, C 註解選定內容
CTRL+K, U 取消註解選定內容

在這個清單中,在你按第二鍵之前,可以按也可以不按CTRL鍵。例如,切換書籤指令的快捷方式是先按CTRL鍵和K鍵,然后你可以再按一下K鍵,或再按一下CTRL鍵和K鍵。兩種f方式都可以。

添加新的兩次按鍵的鍵盤捷徑:
1. “說明” -> “鍵盤配置”
2. 在清單中找到“使用者功能表(2)”并雙擊。
3. 在快顯的“所有組態屬性”的對話方塊上“按下新的捷徑”中輸入一個新的捷徑。例如,CTRL+;
4. 點擊「分配」 -> 「確定」
5. 關閉“鍵盤配置”視窗。
6. “工具” -> “自訂功能表”
7. 在“需要定義的功能表清單”下選擇“使用者功能表(2)”
8. 點擊「插入右邊」按鈕。
9.在快顯的“功能表屬性”對話方塊中,選擇一個要添加捷徑的命令
10.在對話方塊中的“名稱”文字方塊中,用“&”指定一個新的捷徑。
11.在“&”的右邊輸入字元,這個字元代表第二次要按的捷徑。

例如,如果你想要給“新增并貼上”命令設置一個兩次按鍵的快捷方式并把”N”設置為第二個捷徑,操作如下:
12.在“功能表屬性”對話方塊中的“類別”組合方塊中,選擇“檔案”。
13.在“命令”組合方塊中選擇“新增并貼上”。
14.在“名稱”文字方塊中輸入”&New and Paste”(“&”右邊的字元”N”代表第二次要按的捷徑)
15.點擊「確定」。

重復以上的步驟,你就可以給你要的許多的命令設置捷徑。

在預設情況下,使用者功能表會在按第一個鍵的1秒后出現。第二個捷徑在使用者功能表出現之前有效。你可以到“自訂功能表”中移動“延時”滑塊,讓功能表出現的時間延長。

CTRL+滑鼠滾輪能改變字型大小,但是你能禁用這個快捷方式嗎?

你可以在“自訂”對話方塊中的“滑鼠”索引標籤上,清除“使用CTRL加滑鼠滾輪調整字型大小”的核取方塊。

雙擊EmEditor中的一個標籤頁可以在一個新視窗中顯示該標籤頁。可以禁用這個功能嗎?

可以。請去“自訂”對話方塊中的“滑鼠”索引標籤上,如果“雙擊滑鼠左鍵”下的下拉單中的選項是“新增分組”,請把它改成“未定義”。

工具

我可以在EmEditor中運行一個外部的編譯器來編譯當前檔案嗎?

請參考FAQ:外部工具組態的例子有哪些? -> 由 Visual C++ 編譯

怎么在Google搜索中尋找當前游標位置出的單字?

請到“工具”功能表下的“外部工具”中,選擇“自訂工具”,然后點擊「新增」按鈕,在“命令”文字方塊中輸入“http://google.com/search?q=$(CurText)”

我想要用一個外部工具在命令提示字元中編寫已打開的檔案,但是在編譯完成后我怎么讓命令提示字元視窗儲存開啟?

選擇“外部工具”子功能表下的“自訂工具”,點擊「新增」按鈕并在“命令”文字方塊中輸入“cmd.exe”,然后在“參數”中輸入:/k “filename” $(Path) 。

外部工具組態的例子有哪些?

  • 打開Internet瀏覽器
    命令: C:\Program Files\Internet Explorer\iexplore.exe
    參數:$(Path)
    初始目錄: $(Dir)
    圖示路經: C:\Program Files\Internet Explorer\iexplore.exe
    檢查儲存檔案
  • 打開檔案總管
    命令: %WinDir%\explorer.exe
    參數: $(Dir)
    初始目錄: $(Dir)
    圖示路經: %WinDir%\explorer.exe
  • 打開命令提示字元
    命令: %WinDir%\system32\cmd.exe
    參數: $(Dir)
    初始目錄: $(Dir)
    圖示路經: %WinDir%\system32\cmd.exe
  • Visual C++ 編譯
    命令: %WinDir%\system32\cmd.exe
    參數: /k “C:\Program Files\Visual Studio\Vc7\bin\vcvars32.bat”&&cl $(Path)
    初始目錄: $(Dir)
    圖示路經: C:\Program Files\Visual Studio\Common7\IDE\devenv.exe
    檢查儲存檔案
  • 執行相關程式
    命令: $(Path)
    參數:
    初始目錄: $(Dir)
    圖示路經:
    檢查儲存檔案
  • Google搜索在游標處的單字或一段選取的文字。
    命令: http://google.com/search?q=$(CurText)
    參數:
    初始目錄:
    圖示路經:
  • Microsoft Visual SourceSafe 簽出
    命令: %WinDir%\system32\cmd.exe
    參數: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkout $/(path)/$(Filename).$(Ext) -y(user name)
    初始目錄: $(Dir)
    圖示路經: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
  • 簽入到 Microsoft Visual SourceSafe
    命令: %WinDir%\system32\cmd.exe
    參數: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkin $/(path)/$(Filename).$(Ext) -y(user name)
    初始目錄: $(Dir)
    圖示路經: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
    檢查儲存檔案

你能在命令,參數,初始目錄,圖示路徑中使用下面預先定義的參數。
$(Path) 檔案的完整路徑名稱。
$(Dir) 檔案的目錄名稱。
$(Filename) 副檔名之外的檔案名。
$(Ext) 副檔名。
$(CurLine) 游標處的邏輯行行號。
$(CurText) 選取的文字或在游標處的單字(如果沒有選取的文字)

你還能指定環境變量,例如 %WinDir%。

巨集

我能用VBScript MSgBox功能嗎?

不行。但是,你可以用WshShell的Popup方法。你還能用alert或confirm方法來代替。
請參考“顯示一個消息方塊”。

我能把多個巨集儲存到檔案中嗎?

可以,你能通過“儲存巨集”命令把已錄制的巨集儲存到檔案中。

視窗

分割視窗有什么作用?

當你在文字底部編寫時,分割視窗可以讓你同時檢視文字頂部。你不能在分割視窗的每一個窗格中打開不同的檔案。

怎么儲存EmEditor視窗的大小,并能在每次打開EmEditor時一直保持這個視窗的大小?

首先,請把EmEditor視窗調整到合適的大小,然后選擇“工具”功能表下的“自訂”,到“視窗”索引標籤上,點擊「儲存當前視窗位置」按鈕,然后點擊「確定」。

怎么能使每次打開EmEditor視窗時都最大化?

首先,請最大化EmEditor視窗。選擇“工具”功能表下的“自訂”,到“視窗”索引標籤上,點擊「儲存當前視窗位置」按鈕,再勾選“還原視窗位置”核取方塊,最后點擊「確定」。

怎么儲存所有EmEditor視窗的當前位置,并在下次開啟EmEditor時,同時打開所有的視窗?

用滑鼠左鍵點擊EmEditor的系統匣圖示來顯示系統匣圖示功能表,并且選擇“儲存工作區”命令來儲存所有的檔案名和當前工作區的游標位置。下次,你可以選擇“還原工作區”命令來還原以前儲存的視窗,包括同樣的檔案名和游標位置。

你也能使用“儲存工作區并全部關閉”命令在儲存工作區后關閉所有視窗,或者用“儲存工作區與所有檔案并全部關閉”命令來在儲存后關閉所有的視窗。

怎么讓EmEditor顯示成一個索引標籤式視窗?

請勾選“啟用標籤”命令。

為什么“重疊顯示”或“並排顯示”命令不起作用?

當“啟用標籤”被選擇時,選擇“重疊顯示”命令或任何“並排顯示”命令會讓標籤頁不能用。這些命令只能用在當許多分組存在時。因此,這些命令沒有任何意義當只有一個群組存在時。這個設定是來自于EmEditor使用者的要求。要像之前那樣重疊或並排,請先禁用標籤頁,然后再選擇命令。即使只有一個群組存在,你還是可以用“新增水平分組”和“新增垂直分組”這兩個命令來並排顯示視窗。

當我關閉最后打開的文檔時,怎么讓EmEditor視窗保持開啟狀態?

請到“工具”下拉功能表中選擇“自訂”,然后選擇“視窗”索引標籤,再勾選“關閉最后的文檔時,不關閉視窗”核取方塊。

能不能在切換標籤時,讓EmEditor從左到右移動文檔標籤?

可以。選擇“工具”功能表下的“自訂”,到“視窗”索引標籤上,清除“點擊‘下一個文檔’命令時切換到上次使用的文檔視窗”核取方塊。當這個核取方塊沒有被勾選時,你可以在標籤文檔之間從左到右(CTRL+TAB)或從右到左( CTRL+SHIFT+TAB )切換文檔。當勾選這個選取方塊時,按下 CTRL+TAB 和 CTRL+SHIFT+TAB ,在活動的文檔和上一次檢視的文檔之間切換。

外掛

怎么能讓工具列自動顯示HTML工具列當打開一個HTML檔案時?

在外掛列上的「HTML工具列」按鈕上單擊滑鼠右鍵,在出現的內容功能表中選擇“屬性”。在彈出的對話方塊中選擇你希望顯示HTML工具列的組態,然后勾選“為選定的組態自動顯示HTML工具列”核取方塊,點擊「確定」,完成設置。當你打開選定的組態時,EmEditor就會顯示HTML工具列。

購買

如果我購買了EmEditor, 我能免費更新到最新的版本嗎?還是每次要更新到新版本時,我都需要付注冊費?

如果您購買的是永久授權,您以後都可以免費更新到最新的版本。

如果您購買的是年訂閱,在第一年內是不需要支付任何更新費用的。第一年之後,如果您要繼續使用EmEditor,需要支付$19.99/年的更新維護費。

如何查找目前安裝的EmEditor的版本號以及更新維護計劃的期限?

到EmEditor中的「說明」菜單下,選擇「關於 EmEditor」命令。然後會「關於 EmEditor」出現對話框。您可以在對話框的上半部分找到版本信息。在「使用者註冊信息」框中您可以看到授權的類型和期限。

年訂閱和永久授權之間的差別是什么?

永久授權讓您能永久使用EmEditor,並且享有免費的升級和更新。
如果您的授權是年訂閱,在第一年之後,如果您想要繼續使用軟件,您需要支付更新維護費($19.99/年)。

當我試著更新EmEditor時,我看到對話方塊顯示“您需要購買更新”。我怎么知道我是否需要購買更新?

您可以到我們客戶中心的重新發送註冊金鑰頁面上,輸入您的電子郵箱。如果您持有永久授權或有效的年訂閱,系統會給您發送可用的註冊碼。如果您沒有收到可用的註冊碼,請購買新的授權。

疑難解答

我怎么報告一個損壞?

如果EmEditor有損壞,通常它會在 C:\ProgramData\Emurasoft\EmEditor\Error 資料夾中創建一個損壞報告。請把這個資料夾中最近的檔案(壓縮到一個Zip 存檔)作為附件電郵到tech@emurasoft.com ,請在電郵中描述一下損壞的詳細情況,包括重現問題的步驟。

當我啟動EmEditor時,它會加載以前運行的大檔案。我怎么禁用自動加載?

如果EmEditor試著加載上次使用的工作區,你可以在命令提示字元中,運行:

emeditor.exe /clw

在運行這個命令后,上次使用的工作區就會被刪除,EmEditor 會啟動一個未命名視窗。

下載

哪里可以下載EmEditor免費版?

EmEditor 免費版和 EmEditor 專業版使用一樣的二進位程式。你可以在我們的下載頁面下載EmEditor 免費版/專業版。在你安裝EmEditor后,你可以選擇降級到免費版。你可以在“快速啟動”(Ctrl+Q)中輸入”降級”來啟用“降級”命令。另外,請參考怎么在專業版和免費版之間切換的說明

哪里可以下載舊版的EmEditor?

舊版的安裝程式能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 資料夾中找到。